Skip to content

KNX IoT Point API Stack

KNX IoT builds on IETF and IEEE standards combined with existing KNX application data descriptions (functional blocks, properties, and data point types). The KNX Association provides standardized APIs, specifications, and a shared information model (semantic project export/import model) for integrating KNX IoT devices into a KNX system. The information model defines application behavior and device locations, enabling automated system integration.

Specifications and OpenAPI Files

Specifications 3-10-5 KNX IoT Point API and 3-10-6 KNX IoT Router are available at schema.knx.org.

The Point API Schema provides a mapping of KNX application data to a RESTful resource model and CBOR/JSON-based data representation. Devices use this representation to communicate over CoAP/UDP and IP. The Point API contains the following building blocks: Discovery, Security, S-Mode messaging and read/write/subscribe access to parameter and diagnostic properties.

Point API Stack

Discovery

Service clients can perform resource discovery either with CoAP unicast/multicast or with mDNS. Multicast resource discovery in CoAP (CoRE) works through the use of a well-known resource URI. This URI returns a list of links about resources hosted by that server (functional blocks and properties) that match filter attributes.

  • Device discovery utilizing DNS-SD and mDNS per RFC 6762
  • Semantic discovery in line with KNX Volume 7 (functional blocks)

Cybersecurity

Either TLS or OSCORE secures group communication and access to parameter and diagnostic properties.

  • OSCORE (RFC 8613) for application-layer security supporting unicast, multicast and low-latency communication
  • SPAKE2+ (RFC 9383) for password-based mutual authentication and session key derivation (PASE)
  • Optional TLS (RFC 5246) for transport-layer encryption during commissioning and LDevID enrollment

Point Read/Write/Publish/Subscribe (r/w/pub/sub)

The system uses parameter and diagnostic properties for sensor, actuator, parameter, and diagnostic values, such as getting the current sensor value or setting a setpoint. Each parameter and diagnostic property has a unique URI. Devices or services can directly access them (GET) and optionally manipulate (PUT) or subscribe (Observe).

  • Smooth integration with non-KNX Systems via standard CoAP (RFC 7252)
  • Content-format options including CBOR (RFC 8949) and JSON (RFC 8259) for flexible data representation

Group Communication (S-Mode)

KNX S-Mode messaging uses a secure message-oriented communication pattern for group communication. A producer sends a message to notify consumers of a change in the domain. The producer does not require a response, if a response exists, it arrives indirectly through a separate group event. ETS (commissioning tool) configures group events via group tables.

  • Integration with KNX Classic and compatibility with ETS
  • CoAP/UDP communication for resource-constrained devices, ensuring efficient memory and message size management
  • Unicast and Multicast communication using CoAP/UDP for low-latency applications